Si eres contador, esto te interesa!!

Si eres contador, esto te interesa!!
JASRCpaqi

viernes, 27 de diciembre de 2013

Funcion SI o IF.

Función SI o IF.

Hola que tal, como lo prometí tenía ya preparada la publicación de esta función por lo que decide de una vez hacerla pública.

La función SI devuelve un valor si la condición especificada resulta verdadera, y otro valor en caso de la condición especificada sea falsa.

Sintaxis de la función:
SI([prueba_lógica], [Valor_si_verdadero], [valor_si_falso])

Prueba lógica = Cualquier valor que pueda evaluarse con verdadero o falso.
Valor si Verdadero = Es el resultado que se devolverá en caso de que la condición especificada resulte verdadera.
Valor si Falso = Es el resultado que se devolverá en caso de que la condición especificada resulte falsa.

En caso de que no se especifique nada en los valores si_verdadero o si_falso, entonces conforme al resultado la formula devolverá 0 en caso de que que no se especifique nada en el valor si_verdadero, o Falso en caso de que no se especifique nada en valor si_falso, para los casos respectivamente la formula quedaría así: SI(A2>20000,,"NO") = 0  o  SI(A2>20000,"SI") = Falso, para la primera formula significa que la condición se evalúa como verdadero y para la segunda la condición se evalúa con falso.

Ejemplo a utilizar =SI(A2>20000,"SI","NO"). En especifico la fórmula evalúa si el valor dentro de la celda “A2” es mayor a 20000, si el valor es mayor a 20000 devolverá un “SI” tal como se especifica la fórmula en el argumento si el valor es verdadero, en caso contrario devolverá un “NO”.


En la próxima publicación estaremos analizando la utilización de las funciones BuscarV y SI ambas en una misma fórmula anidada.

Saludos Cordiales
JASR

jueves, 26 de diciembre de 2013

Estructura de un procedimiento (Macro Excel) Visual Basic

Por error borre esta entrada,  por lo que la estoy republicando. Fecha de publicacion anterior 13/11/2013 

Del ejemplo anterior en donde se publico como se grava una macro y el código que se obtiene.
Ahora nos preguntaremos que quiere decir todo esto. Bueno veamos.

 Sub Nombre () significa el inicio del procedimiento y
Las lineas en las que precede un apostrofe indica que esas lineas no son leídas por el procedimiento.
aquí en medio se escribe lo que hará el procedimiento.
End Sub Significa el fin del procedimiento.

 Sub Nombre()
'
' Nombre Macro
' Esta macro sirve para escribir mi nombre y la fecha del día.
'
    Range("A1").Select
    ActiveCell.FormulaR1C1 = "mi nombre escrito por una macro grabada"
    Range("A2").Select
    ActiveCell.FormulaR1C1 = "10/5/2013"
    Range("B2").Select
 
End Sub

A Continuación se mencionan alguna de las propiedad que se utilizan de forma regular en la
grabación de las macros y así como para poder personalizarlas.
Estos son algunos de las propiedad mas utilizadas:

ActiveCell  --- Que hace referencia al objeto de una celda activa.
Range --- A un rago de celdas.
Worksheets  --- Contiene la colección de hojas del libro.
Workbooks --- Se refiere al libro
ActiveSheet --- Hace referencia a la hoja activa.
Cells --- coleccion de celdas de un libro.
Selection --- Hace referencia al objeto seleccionado. (Celda o Columna)
ThisWorkBook  --- Hace referencia al libro en uso.
Ejemplos de como se podría usar, estos son algunos de los ejemplos que se pueden llevar a cabo de muchos que se puede realizar con estos objetos.

Sub celdaactiva()
      'Vamos a insertarle un valor a una celda activa.

       ActiveCell.Value = "Mi celda Activa"

End Sub
 

 Sub rangos()
    'vamos a seleccionar un rango de celda.

    Range("A1:b15").Select

End Sub


Sub workbokks()
    'Haremos que se guarde los cambios de un determinado libro abierto
    Workbooks("Milibro.xlsx").Save
End Sub


Sub activeshet()
    'Vamos a darle un nombre nuevo a la hoja activa-
    ActiveSheet.Name = "Hoja Activa"

End Sub


Sub cellss()
    'vamos ubicar una celda y darle un valor y seleccionarla
    Cells(3, 3).Value = "Celda buscada"
    Cells(3, 3).Select
End Sub

 Sub seleccion()

    'de la celda o celdas seleccionadas daremos un valor.
    Selection.Value = "hola"
End Sub

Sub ThisWorkbooksss()
    'vamos a guarda el libro actual o en uso.
    ThisWorkbook.Save
End Sub

Para la utilizacion de estas macros pueden pegar el código directamente en el editor de visual basic de excel y probarlas y analizar su código.
Eso es todo por hoy espero y les sirva para aquellos que empiezan a incursionar en la poderosa hoja de excel.

Saludos Cordiales.

JASR

Formulas en excel. BuscarV

Hola amigos.
Una vez más estamos con ustedes para explicarles la utilización de las formulas en Excel.
En esta ocasión abordaremos una de las formulas mas utilizadas, bueno por lo menos en mi caso es una de las que mas utilizo dado que manejo mucha información proveniente de bases de datos.
La funcion BuscarV(VLOOKUP)
Las sintaxis de la funcion es la siguiente:

BuscarV(“valors buscado”,”rango de búsqueda”,”Numero columna”,” Falso(0) o Verdadero(1))

Valor buscado = Es el valor de coincidencia que se desea buscar en el rango de búsqueda.
Rango de Busqueda = Es la matriz de búsqueda.
Numero columna = Es el numero de la columna contando de izquierda a derecha donde se encuentran los posibles valores coincidentes.
Falso o Verdadero = Si se coloca falso o 0 indicara a la formula que tiene que buscar registros pero con coincidencias exactas, si coloca verdadero o 1 indicara a la formula que tiene que buscar registros sin importar el orden de los datos lo cual quiere decir que la primera coincidencia es la que arrojara la formula y cuando se trate de valores numéricos la formula encontrara el valor más cercano.

Ejemplo con los siguientes datos del Libro:


Se tienen dos hojas de datos una donde se desea saber la descripción del proveedor  (Resumen Compras), y la otra donde se encuentra el datos (Datos). La formula quedaría de la siguiente manera:



En este caso el cuadro de dialogo muestra el resultado que devolverá la formula = “Proveedor 3”.
En la celda don se escribe la formula deberá verse de la siguiente manera: =BUSCARV(A2,Datos!A:B,2,FALSO) esto conforme a la sintaxis descrita.

En la siguiente publicación estaremos analizando la formula “SI o IF”.


Saludos cordiales
JASR